Membuat Dynamic Routing pada Router Cisco


Buat teman-teman telkom elektro ITS (e47 dan e48), terima kasih atas kesempatan yang diberikan kepada saya untuk menjadi trainer lagi. Sebuah persembahan saya buat lab B.301 yang telah membesarkan saya, yang memberikan banyak ilmu buat saya, menjadikan saya dari nol menjadi seperti sekarang ini.Langsung saja masuk ke tutorialnya, kali ini kita akan membuat jaringan dengan menggunakan tiga buah router dengan menggunakan dynamic routing. Routing yang akan kita gunakan di sini adalah RIP. Topologi yang akan digunakan adalah sebagai berikut.

Topologi Jaringan

Jaringan Router 0 (Router Tengah)

  • Interface FE 0/0    : 202.46.129.2/24
  • Interface FE 0/1    : 10.10.10.1/24
  • Network ID Client    : 10.10.10.0/24

Jaringan Router 1 (Router Kiri)

  • Interface FE 0/0    : 202.46.129.1/24
  • Interface FE 0/1    : 172.15.1.1/24
  • Network ID Client    : 172.15.1.0/24

Jaringan Router 2

  • Interface FE 0/0    : 10.10.10.2/24
  • Interface FE 0/1    : 192.168.100.1/24
  • Network ID Client    : 192.168.100.0/24

Sekarang kita setting Router 0 terlebih dahulu. Pertama, kita hubungkan PC dengan router. Caranya ada di postingan sebelumnya. Jika telah terhubung, ketikkan command berikut pada hyperterminal.

--- System Configuration Dialog Router 0---

Continue with configuration dialog? [yes/no]: n

Press RETURN to get started!

Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 202.46.129.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 172.15.1.0
Router(config-router)#network 192.168.100.0
Router(config-router)#network 202.46.129.0
Router(config-router)#network 10.10.10.0
Router(config-router)#

Untuk router 2, command yang harus diketikkan adalah sebagai berikut.

         --- System Configuration Dialog Router 1 ---

Continue with configuration dialog? [yes/no]: n

Press RETURN to get started!

Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 202.46.129.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 172.15.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config)#router rip
Router(config-router)#network 10.10.10.0
Router(config-router)#network 192.168.100.0
Router(config-router)#network 202.46.129.0
Router(config-router)#network 172.15.1.0
Router(config-router)#exit

Sedangkan pada router 3, masukkan command berikut ini.

         --- System Configuration Dialog Router 2 ---

Continue with configuration dialog? [yes/no]: n

</code>Press RETURN to get started!

Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 10.10.10.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.100.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 10.10.10.0
Router(config-router)#network 172.15.1.0
Router(config-router)#network 202.46.129.0
Router(config-router)#network 192.168.100.0
Router(config-router)#exit

Kalo semua router sudah disetting dan dikonfigurasi, sekarang saatnya menguji apakah jaringan yang kita buat sudah terhubung. Koneksikan semua router dengan PC melalui switch. Setting network address masing-masing komputer sesuai dengan gatewaynya. Berikut ini contohnya. GW adalah default gateway.

  • PC0   : 172.15.1.10/24 GW 172.15.1.1
  • PC1    : 172.15.1.20/24 GW 172.15.1.1
  • PC2    : 10.10.10.10/24 GW 10.10.10.1
  • PC3    : 10.10.10.20/24 GW 10.10.10.1
  • PC4    : 192.168.100.10/24 GW 192.168.100.1
  • PC5    : 192.168.100.20/24 GW 192.168.100.1

Kalau pada postingan sebelumnya kita sudah membuat jaringan dengan topologi yang hampir sama dengan menggunakan static routing, sekarang kita pakai dynamic routing. Lalu apa bedanya??

Pada static routing, administrator memasukkan tabel routing ke dalam router satu per satu. Metode ini cocok digunakan untuk jaringan yang kecil. Jika ada perubahan terhadap topologi jaringan, administrator tidak terlalu repot untuk mengupdate tabel routingnya karena jumlah routernya tidak terlalu banyak.

Berbeda ketika kita kita mempunyai jaringan yang besar. Kita tidak mungkin memasukkan tabel routing satu per satu, oleh karena itu kita memakai dynamic routing. Routing protokol akan membuat dan mengupdate sendiri routingnya. Administrator hanya perlu memasukkan network tujuan ke dalam router dan router akan membuat tabel routing sendiri. Jika ada perubahan topologi jaringan, router akan mengupdate sendiri tabel routingnya.

Ada banyak routing protokol yang bisa kita gunakan, seperti BGP, IGRP, EIGRP, OSPF, dll. Namun yang sering dipakai di dunia adalah protokol RIP. Jika pada tutorial di atas kita menggunakan routing protokol RIP, kita bisa menggunakan protokol lain dengan mengganti command router rip menjadi router xyz di mana xyz bisa diganti dengan protokol yang akan digunakan, misalnya bgp. Mudah bukan untuk mensetting router??

Untuk teman-teman TELKOM ITS, sekarang giliran kalian belajar sendiri. Saya sudah mengajarkan dasar-dasar untuk setting router, sekarang kalian yang harus meng-improve diri kalian sendiri. Manfaatkan router yang ada di lab untuk belajar MPLS, IPv6, dan sebagainya. Saya tunggu kontribusi kalian untuk TELKOM ITS.

· Jaringan router 0

o Interface FE 0/0                  : 202.46.129.2/24

o Interface FE 0/1                  : 10.10.10.1/24

o Network ID Client               : 10.10.10.0/24

· Jaringan router 1

o Interface FE 0/0                  : 202.46.129.1/24

o Interface FE 0/1                  : 172.15.1.1/24

o Network ID Client               : 172.15.1.0/24

· Jaringan router 2

o Interface FE 0/0                  : 10.10.10.2/24

o Interface FE 0/1                  : 192.168.100.1/24

o Network ID Client               : 192.168.100.0/24

About these ads
This entry was posted in Ilmiah, Tutorial. Bookmark the permalink.

3 Responses to Membuat Dynamic Routing pada Router Cisco

  1. newbie admin says:

    Bukanya dinamic routing protocol yang dipakai tergantung kebetuhan mas? Misal untuk backbone kita gunakan BGP dan untuk network skala menengah kita gunakan OSPF. Dan menurut saya protokol RIP sudah jarang dipakai.

  2. riyadi2405 says:

    tutorial yang menarik mas….suwun yo…

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s